Canon Print Plug-In for Office Specifications

SUPPORTED PRINTERS

Supported printers

Canon imagePROGRAF series

SOFTWARE REQUIREMENTS

Operating System

Windows 32 bit - Windows XP SP2 or later
Windows 64 bit - Windows Vista or later
*Please find the software updates in Canon Software Download Centre

Application Software

Microsoft Office 2000 / Office 2003 / Office 2007 / Office 2010 / Office 2013
(Word / PowerPoint / Excel)
*Office2010/2013 64bit version are not supported